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Overview 
This is the operator’s manual for the Micro-g LaCoste TAGS-7 
PiperPro Processing Software. The software provides 
sophisticated data collection and processing.  Post-processing is 
done using MGL’s AGSys or client’s own processing software. 

For operation of the TAGS-7 gravity meter hardware, refer to 
the appropriate hardware user’s manual. 

System Requirements 
PiperPro runs on any computer with the following minimal 
standards: 

Operating System: Windows 7 and newer 

Free Hard Drive Space: 1 GB or greater 

RAM: 2 GB or greater 

Processor: Intel™ i3 or greater (AMD also works with 
similar standards) 

Processing Speed: 2 GHz or greater 
 

Conventions 
Dialog box menus, commands, dialog box titles, labels and 
options are bolded text in the user instructions. WARNING and 
IMPORTANT notes are highlighted in red. 
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PiperPro Software 
Licensed users of PiperPro can download the latest PiperPro 
software (PiperPro.exe) from: 

 http://www.microglacoste.com/PiperPro/  

After installation, check that the files listed in Table 2-1 are 
present on the local machine. If you do not have all the listed 
files and/or directories once PiperPro is installed, please contact 
Micro-g LaCoste. 

Table 2-1 Installation Files 

Filename Description 

Program Files\PiperPro\readme.txt  Overview of installation procedures. 

Program Files\PiperPro\PiperProHelp.pdf  This document. 

Program Files\PiperPro\bin\PiperPro.exe Main application. 

gInfo\PiperProDisplay.ini Configuration information for PiperPro.exe. 

Program Files\PiperPro\License.txt Standard software licensing information. 
 

Installation Procedure 
NOTE Before beginning installation, be sure to uninstall any previous 

version of PiperPro.  

Double click the Install application (PiperPro_Setup.exe). 

• Follow the displayed instructions.  
• It is highly recommended that you accept ALL default 

settings. 
• Double click on the newly installed PiperPro program icon.  
• Select “generate” when prompted.  

o This creates a SysChk.bin file that is unique to this 
computer.  

o Note where it is located on your local hard drive.  
o Email this SysChk.bin to Micro g at: 

info@microglacoste.com 

http://www.microglacoste.com/PiperPro/
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o Wait for us to send you PiperProPWinfo.bin. This 
usually takes less than 24 hours during a normal 
business week.  

 
NOTE The SysChk.bin files are unique for each computer, so please 

send one file at a time. 

• Upon receipt of PiperProPWInfo.bin, manually copy the file 
into the newly created gInfo. (Usually c:\gInfo).  

• Double click on the PiperPro program icon.  
o Select Install. (May not be required if password is 

recognized automatically) 
o You may be asked to point to the PiperProPWInfo.bin 

file on your local hard drive.  
 
IMPORTANT  Due to details in the software protection of PiperPro, if at any 

time the user adds or removes hardware from the computer, it 
may be necessary to obtain a new password file by following the 
above steps.  

• Next, create the directory c:\gData\PiperPro if it does not 
already exist.  

o This is the default location for all PiperPro data. 
 

You are now ready to run PiperPro. 
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Local Configuration File  
Local .ini File 

All processing parameters for the loaded data are stored in the 
local PiperPro.ini file located in the same folder as the data. 
Changes to this .ini file only affect the data in that folder when 
reprocessed.  

NOTE To save the processing parameters changes to the PiperPro.ini 
file, select Save from the File menu. Note that the settings are 
automatically saved when processing starts (Select Start from 
the Reprocess menu). 

Modify System Setting Parameters 
 The processing parameters may be modified from the System 
menu and clicking Settings. (or F3). There are three tab pages 
(Setup, Calibration and Corrections) contained in the System 
Settings dialog.  

 

Figure 3-1 System Settings Dialog: Setup Tab Page 
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Setup Tab 

The Setup tab page configures the instrument setup 
parameters. Refer to Table 3-1 for a description of each of the 
setup parameters. Figure 3-1 shows the Setup tab page. 

Table 3-1 System Settings Dialog: Setup Tab Page Parameters and Descriptions 

Section Parameter Description 

Meter Type:  Click to select the Meter type that is running, TAGS-7  

Freq Click to select the Frequency.TAGS-7 runs at 20Hz 
only.  

Name/ID Serial number of the meter. 

Raw Gravity Window(s) Total seconds plotted for raw gravity. After this total 
has been reached, graphs scroll horizontally. 

Filtered Data 
 

Window(s) Total seconds plotted for one second data plots. After 
this total has been reached, graphs scroll 
horizontally. 

Filter  
 

Levels Checking the Levels box enables a 20Hz to 5 second 
filter on the levels data. If this is disabled, the levels 
are filtered to 1 Hz data instead. (This is only a 
graphical filter. This filter is not applied to recorded 
data in files.  

Exact 
Blackman Filter 
(Gravity) 

Checking the Exact Blackman Filter (Gravity) box 
enables a FIR (Finite Infinite Response) Exact 
Blackman filter on the 1 Hz gravity data. Refer to 
Appendix B for the QC filter computation. 

Window (s) The window text field is the filter length for the Exact 
Blackman Filter. 

File type Dat or TSoft Select the output file type. The Dat files are comma 
delimited ASCII files that can be read using a 
spreadsheet application. TSoft files are tab delimited 
files, with detailed header and can be imported into 
the TSoft reprocessing software. 

Meter 
Communication 

Setup Click the Setup button to configure communication 
settings.  

GPS 
 

Off If no GPS is connected. 

From Meter NA for TAGS-7 

From Vessel NA for TAGS-7 

http://appendixb.doc/
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Section Parameter Description 

GPS Time 
Stamp 

Enabled Click to enable the GPS Time Stamp. If the GPS Time 
Stamp is enabled, the software looks for the GPS 
timestamp from the meter instead of using the PC 
clock. Otherwise, the PC clock is used for the initial 
data time stamp. 

Output file 
Backup 

Enabled Click Enabled to send the backup file to another 
location. 

Output Data to 
Serial 

Enable Click Enabled to send data to an external location 
through the serial port. Click the Setup button to 
configure communication settings and data format. 
Refer to the Serial Output Section for additional 
information. 

 

Serial Output Setup 

Under the System menu select the System Settings option to 
access the Setup tab page where data can be configured to be 
sent to an external location. In the Output Data to Serial 
section, click Enable then click Setup to access the Serial 
Output Setup dialog (Figure 3-2). Refer to Table 3-2 for a 
description of each of the output options. 

 

 

 

 

 

 

 

 

 
 

Figure 3-2 Serial Output Setup Dialog 
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Table 3-2 Serial Output Setup Table Description 

Option Description 

Port Settings Click Setup and configure the port settings.  

Checksum Choose a checksum option. 

String Width  Choose a string width. 

Field Delimiter Choose a field delimiter. 

String Termination  Choose a string termination. 
 

Calibration Tab 

The Calibration tab page shows the current calibration of the 
meter. The calibration factors change if the meter is serviced 
and/or altered. Figure 3-3 shows the Calibration tab page. The 
calibration parameters are described in Table 3-3. 

 

Figure 3-3 System Settings Dialog: Calibration Tab Page 
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Table 3-3 System Settings Dialog: Calibration Tab Page Parameters and Descriptions 

Section Parameter Description 

Gravity Reference This is an offset for gravity. Add the absolute 
value here for your location to offset the 
incoming gravity. This is required for IGF 
correction. 

Cal Factor The calibration to convert the input gravity 
value into mGals. 

Meter Temperature Expected (°C) The expected meter temperature for the 
current instrument. If the meter temperature 
is not within ± ½ degree C, then a warning 
pops up during data acquisition.  

Gain / Zero Long/Cross Level, 
Meter Temperature, 
Meter Pressure, 
Beam, Long Gyro, 
Cross Gyro 

These are the calibration factors used to 
convert the raw input values into their correct 
units. 

 

Corrections Tab 

 

Figure 3-4 System Setting Dialog: Corrections Tab Page 
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Use the Corrections Tab page to enable Eötvös and/or IGF 
(International Gravity Formula, GRS80) correction and set the 
VCC coefficient level. Figure 3-4 shows the Corrections tab 
page. The TAGS-6 corrections are done post processing. 

Eötvös Correction 

Eötvös correction in milliGal: 

     Ecorr = 7.503 v cos(λ) sin(α) + 0.004154 v 2 

Where: 

v = ship’s speed in knots 

λ = latitude 

α = ship’s course heading (0° is due north, 90° is due east) 

IGF Correction 

    International Gravity Formula, GRS80: 

   

Where: 

λ = latitude 

g is in milliGal 

VCC Coefficient Level  

 VCC = Beam ∙ LongLevel ∙ VCC Coefficient 

Where: 

Beam = Meter beam position 

LongLevel = meter long level 

VCC Coefficient = VCC Coefficient entry in the Corrections tab page.  

  (To access, select Settings under the System menu.) 
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PiperPro Main Window 

 
Figure 4-1 Example PiperPro Main Window with Several Views Selected 

The main PiperPro-1 window (Figure 4-1) always displays the 
PiperPro Data view (Figure 4-2). It is the main view used to 
convey meter status and cannot be closed.  

There are ten other selectable views available to the user: 

• Raw Gravity 
• Filtered Gravity 
• Environment 
• Levels 
• Corrections 
• Feedback 
• Gyros 
• Lag Corrections 
• Controls 
• Navigation Plot 
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Under the View menu, click on the desired view to toggle the 
view On/Off.  Figure 4-1 shows an example setup of the 
PiperPro main window with several views selected.  

PiperPro main window remembers and displays the last selected 
views and their positions.  

Use the Window menu, to choose Cascade or Tile layout style. 

PiperPro Data View 

 

Figure 4-2 PiperPro Data View 

Figure 4-2 shows an example of the PiperPro Data view. Refer 
to Table 4-1 for description of the PiperPro Data view 
parameters. 

Table 4-1 Parameter Description of PiperPro Data View 

Section Parameter Description 

Setup Meter 

Time (GMT) 

Shows the meter number and the 
current time (GMT). 

Gravity Filtered (mGals) Provides information about the 
current filtered gravity value 
(mGals) 

Levels Long Level Displays the current long and cross 
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Section Parameter Description 

Cross Level level position values. 

Environment Meter Temp (°C) 

Meter Press (mbar) 

Shows the current meter 
temperature and pressure. 

Meter ACSII Output Meter ACSII Output Displays the raw serial string 
acquired from the meter. 

Meter Status Meter Status This displays meter status 
information: ONLINE, TURNING, 
UNCLAMP, CLAMP  

ONLINE 

TURNING 

UNCLAMP 

CLAMP 

Use the system buttons to 
communicate with the meter. The 
meter can be placed in TURNING or 
ONLINE mode or the operator can 
CLAMP or UNCLAMP the meter. 

 Beam The current beam position is given 
and shown on the dial. 

 VCC Calculated VCC cross coupling. 

 Eötvös The Eötvös correction. 

 IGF The IGF correction. 
 

Raw Gravity View 

 

 

 

 

 

 

 

 

Figure 4-3 Raw Gravity View 
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The Raw Gravity view (Figure 4-3) displays the raw 1 Hz or the 
20 Hz gravity as it was received from the meter. The graph 
automatically scrolls after a set amount of time passes. 

The Raw Gravity view time range is set on the Setup tab page 
of the System Settings dialog in the Window(s) parameter of 
the Raw Gravity section. To access click Settings under the 
System menu.  

Filtered Gravity View 

Figure 4-4  Filtered Gravity View 

The Filtered Gravity view (Figure 4-4) displays the corrected 
gravity data. The graph automatically resizes to fit all the data 
across the graph. The data fit time range is set in the Window 
(s) parameter in the Filtered Data section on the Setup tab 
page in the System Settings dialog. Click Settings under the 
System menu. The graph scrolls when the data exceeds the set 
range.  

Environment View 

The Environmental view (Figure 4-5) displays the 
environmental data received from the meter, which includes 
meter temperature and pressure, beam position and VCC 
calculations.  
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The data fit time range is set in the Filtered Data Window (s) 
parameter on the Setup tab page of the System Settings 
dialog. Click Settings under the System menu.  

 

 

 

 

 

 

 

 

 

Figure 4-5 Environment View 
Levels View 

Figure 4-6 Levels View 
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The Levels view (Figure 4-6) displays the level data received 
from the meter, which includes long level and cross level. The 
levels data fit time range is set in the Window (s) parameter in 
the Filtered Data section on the Setup tab page in the 
System Settings dialog. Click Settings under the System 
menu.  

Corrections View 

Figure 4-7 Corrections View 

The Corrections view (Figure 4-7) displays the Eötvös and IGF 
data corrections received from the meter. Enable corrections 
from the Corrections tab page under the System Settings 
dialog. Click Settings under the System menu.  
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Controls View 

Figure 4-8 Controls View 

The Controls view (Figure 4-8) shows real time meter status in 
a more visual type display. Certain fields may not update, 
depending on your GPS status.  
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Navigation Plot View 

The Navigation Plot (Figure 4-9) plots the current run latitude 
and longitude on a graph so you can see what your course has 
been. The latitude and longitude max/min can be set using the 
lower text boxes or set to be automatic. In order to update the 
min/max, click Update. The navigation plot will not update if 
there is no GPS input or the meter is stationary. 

Figure 4-9 Navigation Plot View 

Modifying The Views 
Reset All Graphs 

Selecting Reset All Graphs under the View menu, clear and 
resets all graphs. Resetting the view(s) only clears the view, it 
does not clear the data from the data files or filters. 

Every view can also be cleared and reset by unselecting and 
reselecting the view from the View menu.  
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Customize Graph Style 

The graphic appearance can be customized by double clicking on 
the graph to bring up the customization dialog. Figure 4-10 
shows an example Gravity Customization dialog. To display 
the default configuration, simply close the graph and reopen it 
from the View menu. 

 

 

 

 

 

 

 

 

 

 

Figure 4-10 Gravity Customization Dialog 

 

IMPORTANT Viewing many graphic displays can slow down data processing. 
Typically not an issue for the supplied laptops, however, user 
supplied laptops must meet or exceed specifications of the 
supplied laptops. 

 If your system does NOT have a good graphics card (>32mb on-
board memory) or the system is running slower than 
anticipated, minimize the number of open views. 

For a full screen view of the graph, click the Maximize button in 
the bottom right corner of the Gravity Customization dialog. 
To close the maximize view, press the Esc key.  
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To export the view, click the Export button in the bottom right 
corner of the Gravity Customization dialog. Select the file 
type, destination and size then click Export.  

Modify Y-Axis 

To customize the y-axis for each graphic, from the System 
menu select Graphics. In the Graphics Setup dialog set the 
Max and Min range for each graphic. Refer to Section 07 
Additional Menu Options, “Graphics” for detailed information.  

 

about:blank
about:blank
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Before acquiring new data, open the program and make sure 
the system settings are set correctly for the meter as well as for 
the user preferences. From the System menu select the Settings 
option. Once the acquisition has started, most of these settings 
cannot be changed.  

IMPORTANT The time on the PC Clock must be set to Coordinated Universal 
Time (GMT), not local time, with daylight savings disabled.  

To acquire new data: 

● From the File menu select New. 
● Then select the directory for the data to be stored when 

prompted and the filename if you have a TAGS-7 instrument. 
● If Output File Backup is enabled in the Setup tab of the 

System Settings dialog, you will be asked to select the 
secondary backup location and filename. 

Directory Selection 
It is recommended that you create a different directory for each 
new acquisition especially if parameters change. The newly 
created directory not only stores the data, but it also stores a 
new, local PiperPro.ini file.  

This local PiperPro.ini file must accompany the data if it is 
moved (or archived) because it contains the settings for that 
particular acquisition. The default directory used at 
Microg LaCoste for storing all the data directories is 
C:\gData\PiperPro. This directory can be created by the user 
after installation if it does not already exist.  

Acquiring Data 
Once a directory and file have been selected, PiperPro begins 
receiving data and updating the view windows. At this point, the 
system is storing data.  

IMPORTANT TAGS-7 data is stored in a user specified file and only one file is 
appended to for the entire survey.   
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The TAGS-7 meter outputs raw data at 20Hz. PiperPro also 
records raw data (*.txt file) at 20Hz. In addition, PiperPro also 
records 1Hz data (.DAT or .TSF file). 

The .DAT files are comma delimited plain ASCII files that can be 
read using a spreadsheet application. Whereas the .TSF(TSoft) 
files are tab-delimited files that have a detailed and specific 
header and can be imported into the TSoft reprocessing and 
analysis software. 

Reset Graphs 

Once the data is deemed acceptable, the meter should be set to 
Online. Once data is being acquired, reset all the graphs views 
by selecting Reset Graphs under the View menu. 

Data Files 

The raw data (*.txt files) is stored every time new data is 
acquired from the meter. The text output files (.DAT or .TSF) 
are also updated once every second. 

TAGS-7 Timing 
Meter Data 

The TAGS-7 meter outputs data at a rate of 20Hz. A data packet 
is a serial ASCII string sent from the TAGS-7 meter that 
contains meter data such as Gravity, Temperatures, Levels, etc. 
You can view the raw ASCII string in the Meter ASCII Output 
located in the PiperPro Data window. 

GPS Synchronization 

The TAGS-7 timing box is equipped with a GPS unit. This GPS 
unit synchronizes with the onboard rubidium clock if connected 
to an external antenna and a valid GPS signal is attained. Once 
a GPS lock is attained, PiperPro can then synchronize the 
onboard rubidium clock to the GPS clock. To do this select 
Synchronize Clock in System. 

In order for PiperPro to check for a GPS time stamp during 
acquisition, the Enabled check box must be checked in the GPS 
Time Stamp section. This option is found in the Setup tab 
page accessed by selecting Settings under the System menu. 
If checked, PiperPro checks for a valid GPS signal from the 
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timing box when starting the acquisition of new data. A warning 
will pop up if a valid GPS signal is not received. If a valid signal 
is not received, the software automatically uses the PC clock for 
the time stamp.  

GPS Data 

No GPS data is directly sent to PiperPro through the serial port 
to the system computer. However, the meter data string 
contains a GPS timestamp that is used to timestamp the data. 
In order to get a valid timestamp, the GPS must be synced. 
Otherwise, the timestamp will just be an incrementing time 
starting from a default time stored in the timing unit.   

NOTE A GPS lock can take up to 20 minutes depending on location, so 
it is best to obtain a valid lock before starting acquisition. 

Graphics 
The user can: 

● Change the graphics settings. 
● Update the graphing windows by closing and reopening the 

graphic window. 
● Manipulate the graphs and locations. 

While data is being received, the user can change the graphics 
by selecting the Graphics options available in the System 
menu. Figure 5-1 shows an example of the System menu. 
Refer to Section 07 Additional Menu Options “Graphics” for 
additional information and example dialog.  

To modify the graphic appearance, double click on any individual 
graph in the PiperPro main window. Refer to Section 04 
PiperPro Main Window And View “Customize Graph Style” for 
additional information. 
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Hardware Communication 
Communicate With Meter 

 

Figure 5-1 System Menu Selection List 

Refer to Figure 5-1 to see list of options available under the 
System menu. The user can: 

● Connect/Disconnect 
● Clamp/Unclamp the meter 
● Stop Clamping/Unclamping 
● Set Feedback On 
● Synchronize Clock/Use Internal Clock 
● Set mode Turning/Online 
● Sync Pc to GPS Time 
● Set Microprocessor Time 

 
The meter sends out a status line to inform TAGS-7 of its 
current status. PiperPro automatically enables and disables 
options based on the status of the meter. 
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View Meter Status 

Status of the meter can be viewed from the status bar or from 
the PiperPro Data window. 

Status Bar 

The status bar, shown in Figure 5-2, can display a variety of 
status indicators and is located in the bottom frame of the 
PiperPro main application window. 

Figure 5-2 Status Bar 

The status bar can display the following information: 

● The current open file. 
● Whether the meter is clamped or unclamped. 
● Whether data is synced to GPS.  
● Whether the data is set to Online or Turning. 
● Whether Feedback is On or Off. 

PiperPro Data Window 

The meter status is also indicated in the PiperPro Data 
window. Refer to Figure 5-3. 

 

Figure 5-3 Meter Status Displayed in PiperPro Data Window 
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This section describes how to reprocess data that has already been acquired. 
Acquiring data in real time is discussed below. 

Starting PiperPro and the Global .ini File 
Start PiperPro by double clicking on the PiperPro icon. The 
PiperPro main window shown in Figure 6-1 will appear.  

NOTE No data is loaded at this point. Any changes made in Settings 
affect the global .ini file. If you change and save any settings at 
this point, the software will warn you that you are making a 
global change that affects all future data acquisition.  

 Refer to Section 03 System Settings “Local .ini File” for more 
information. 

 

Figure 6-1 Open Project File 

about:blank
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Loading Existing Data 
    To load existing data: 

• Select “generate” when prompted.  
o This creates a SysChk.bin file that is unique to this 

computer.  
• From the File menu select Load.  

o The Select Data File dialog opens. Refer to Figure 6-2. 
 

 

Figure 6-2 Select Data File: File Extension Selection 

• Navigate to the desired directory.  
o Select the file for the desired day.  
o The file extensions vary depending upon the system 

and data. Figure 6-2 shows an example selection drop 
down list. 

• The Load Type dialog shown in Figure 6-3 appears.  
o Select the load type (Quick or Visual).Then click OK. 
o Refer to the Load Types section below for additional 

information. 
• The Selection Configuration File browser dialog opens. 

o Navigate to the desired directory. 
o Select the *.ini file for the current configuration file. 
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Figure 6-3 Load Type Dialog 

Load Types 

     There are two different ways of loading and processing files. 

Quick 

Quick load loads and processes the entire data set that you 
select and then graphs the data. This is the quickest way of 
loading and processing the data.  

Visual 

Visual load loads and graphs the data simultaneously. This is a 
much slower approach, but it allows the user to see all the data 
in detail as it is processed. 

Post Processing Data 
To start loading and re-processing data, select Start from the 
Reprocess menu.  

If Quick load was selected, then all the data is initially loaded 
before the graphs and windows are updated.  

If Visual load was selected, then the processing can be stopped 
or paused at any time, and the user-set parameters can be 
changed at any time.  

The user can change any parameters by selecting Settings 
from the System menu (or F3). Refer to Section 03 System 
Settings “Modify System Setting Parameters” for more 
information. To begin processing again, select Start from the 
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Reprocess menu (or F5). The load type cannot be changed 
once the file has begun processing. To change load type, reload 
the file by selecting Load from the File menu.  

During a Visual Load, the user can pause by selecting Pause 
from the Reprocess menu. The user can then select Start (to 
restart the process) or Step (to step through the process) from 
the Reprocess menu. 

Clearing Graph Data 

Every graph can be closed and reopened from the View menu. 
Closing and reopening a graph view clears the data from the 
graph window. You can also clear all data from all graph 
windows by selecting Reset All Graphs under the View menu.  

Customizing Graph Data 

The graphs can also be customized by clicking anywhere on the 
graph to bring up the customization dialog. See Section 04 
PiperPro Main Window And Views “Customize Graph Style” for 
detailed information.  

Each graphs y-axis can also be customized from within the 
Graphics Setup dialog. To access the Graphics Setup dialog, 
select Graphics from the System menu. These values are also 
saved to the *.ini text project file. See Section 07 Additional 
Menu Options “Graphics” for additional details and an example 
dialog.  

To reset the graph after customizations, the user can simply 
close the graph and reopen it.  

IMPORTANT Viewing many graphic displays can significantly slow down data 
processing. 

 If your system does NOT have a good graphics card (>32mb on-
board memory) or the system is running slower than 
anticipated, minimize the number of open views. 
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File 
New 

The New option creates a new project file from the current 
System | Settings. Once an output directory has been selected, 
all the project files are created and data acquisition begins.  

Load 

The Load option loads an existing file. The user can choose 
Quick load or Visual load. The Quick load loads the entire 
selected data set and then graphs the data. This is the quickest 
way of loading the data. The Visual load loads and graphs the 
data simultaneously. This is a much slower approach, but loads 
everything sequentially. 

Close 

The Close option closes an opened file. Upon closing, the main 
PiperPro.ini file is reloaded.  

Save 

The Save option saves the current file. PiperPro warns the user 
if they are saving over the main PiperPro.ini file that is located 
in the software installation directory.  

Exit 

The Exit option exits the program. 

Edit 
Time Offset 

The Time Offset option allows application of a time shift in the 
event that the computer time was not set to the correct time. To 
calculate the offset, change the True Start Time to the correct 
time (the time that should have been). Check the time offset as 
listed in the grayed edit box. If the time offset is correct, check 
the Apply Time Offset option to make the time offset effective 
during processing. This option only pertains to reprocessing of 
data. Refer to Figure 7-1. 
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Figure 7-1 Time Offset Dialog 
Processing Rate 

The Processing Rate sets the processing rate. This option only 
pertains to reprocessing of data. Some computers are slower 
and thus the software allows for more reprocessing time to 
reduce the chances of a computer crash or system overload. 

System  
Settings 

The Settings option allows changes to any of the system 
settings including Setup, Calibration and Corrections. These 
settings are unavailable during real-time acquisition, but can be 
altered before acquisition and reprocessing.  

Graphics 

The Graphics option opens the Graphics Setup dialog which 
allows customization of the y-axis scale for the Raw Gravity, 
Gravity, Environment, Levels and Corrections graphs. Each 
graph can be set up independently to either be auto-scaled or 
user-scaled.  

Figure 7-2 shows an example of the Graphics Setup dialog. 
These values can be saved to the *.ini file so the user does not 
have to reload them each time they start a new acquisition or 
reprocess the data.  

The graphic style is modified in the customization dialog for 
each graph. Access the customization dialog by double clicking 
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on the graph. Refer to Section 04 PiperPro Main Window And 
Views, “Customize Graph Style” for more information. 

 

Figure 7-2 Graphics Setup Dialog 
Connect 

For this release, connect is automated feature. It is placeholder 
for a future usability feature. 

Disconnect 

Disconnects and closes the file. Currently this is a placeholder 
for a future usability feature.  

Clamp 

The Clamp option clamps the meter. 

about:blank
about:blank


 
 

7-4  Additional Menu Options 
 Release 115-780-011A, Release Date 02 May 2024 

Unclamp 

The Unclamp option unclamps the meter. 

Stop Clamping/Unclamping 

The Stop Clamping/Unclamping option tells the meter to stop 
clamping or unclamping.  

Feedback On 

By default always on in order for the meter to work. 

Online 

The Online option tells the meter that you are online. This is 
the ideal mode for acquiring data.   

Turning 

The Turning option tells the meter that you are turning. This 
mode is usually used while the aircraft/ship is turning and is not 
on a stable and direct path. 

Set Limits 

The Set Limits option tells the meter to set its internal limits. 

Synchronize Clock 

The Synchronize Clock option tells the meter to synchronize 
the onboard clock with the GPS clock. Once synchronization is 
achieved, the meter outputs a timestamp with the ASCII serial 
data string. This only pertains to TAGS-6 systems. . 

Turning Sound Enabled 

On the TAGS-7 system, an audible sound (beep) is heard while 
in turn mode. 

Sync PC to GPS Time 

If you have valid GPS and administrator rights to set the 
computer time, this will sync the computer clock to the GPS 
time. 

Terminal Window 

In the Terminal window, (Figure 7-3) type commands to be sent 
to the meter in the text box, then click Send. The Disconnect 
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button disconnects the serial port connection. The Exit button 
closes the Terminal window and disconnects from the serial 
port if necessary. 

Figure 7-3 Terminal Window 

Reprocess 
Start 

The Start option starts the processing in both post-processing 
and real-time acquisition. 

Stop 

The Stop option stops all processing in post-processing or real-
time acquisition mode.   

Pause 

The Pause option pauses processing and can only be used in 
post-processing mode. 
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Step 

The Step option processes data step-by-step in post-processing 
mode only. 

View 
The View menu allows all available graphs to be opened, closed 
or reset. If the graph is currently visible, there is a check mark 
next to the graph in the View menu list. Detailed description 
about the graphs can be found in Section 04 “PiperPro Main 
Windows And Views”.  

Raw Gravity 

Toggles Raw Gravity graph Open/Close. 

Gravity 

Toggles Gravity graph Open/Close. 

Environment 

Toggles Environment graph Open/Close. 

Levels 

Toggles Level graph Open/Close. 

Corrections 

Toggles Corrections graph Open/Close. 

Controls 

Toggles Control View Open/Close.  

Navigation Plot 

Toggles Navigation Plot Open/Close. 

Reset All Graphs 

Resets all graphs. 

Toolbar 

Toggles Toolbar ON/OFF. 

about:blank
about:blank


 

Additional Menu Options  7-7 
Release 115-780-011A, Release Date 02 May 2024 

Status Bar 

Toggles Status Bar ON/OFF. 

Full Screen 

Toggles Full Screen mode ON/OFF. 

NOTE When in full screen mode and the Status Bar, Tool Bar, and 
Menu are not visible they can be enabled by pressing the F12 
key. 

Window 
The Windows menu lets user change the display style and also 
lists the currently open views. 

Cascade 

Displays the selected graphs in cascade mode.  

Tile 

Displays the selected graphs in tile mode. 

Help 
PiperPro Help 

Opens the PDF version of this manual. 

About PiperPro 

Opens the About PiperPro dialog showing the current PiperPro 
version information. 

Update Firmware 

WARNING Only use this option under the direction of a Microg LaCoste 
engineer.  

A firmware upgrade is sent when required . (MGL) engineer. 
Follow the installation procedure under the direction of a 
Microg LaCoste engineer. 

Clicking on Update Firmware brings up the PIC32 
Bootloader Application v1.2 dialog.  Refer to Figure 7-4. 
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Figure 7-4 PIC32 Bootloader Application V1.2 Dialog 

1. Click Connect. 
2. Then click Load Hex File. 

• Select the upgrade firmware file in the displayed browser 
window. 

• Then click Open. 
3. Click Erase Program Verify.  
4. Click Run Application. 

• The Update Firmware program will automatically close 
upon completion.  

Clear Error Log File 

The Clear Error Log File option clears the error log.  
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License Information 
Licensed users of PiperPro are entitled to three install platforms 
with the Main License. Additional installations, including support, 
are purchased one seat at a time directly from Micro-g LaCoste. 
If your institution or company requires PiperPro Processing 
software to run on more than three platforms, please contact 
Micro-g LaCoste directly or visit our website, 
www.microglacoste.com, for more information. 

Support 
Contact 

Questions concerning the operation of the PiperPro Processing 
software and any problems using PiperPro please contact 
Customer Service at info@microglacoste.com. 

Expect a response via email or phone call within forty-eight 
hours of your inquiry. 

Support Request 

Provide complete detailed information to help us respond with a 
more accurate and timely response. Include software release 
version (select About PiperPro under the Help menu), a 
scenario description and list of steps to recreate the problem.  

Maintenance 
Periodically Micro-g LaCoste posts an upgrade “patch” for the 
PiperPro Processing software on the website. These patches are 
posted without notification so check back every few weeks to 
get the latest patch if applicable. 

  

http://www.microgsolutions.com/
mailto:info@microglacoste.com


 
 

8-2  General Information 
 Release 115-780-011A, Release Date 02 May 2024 

 



 

APPENDIX A  DATA RECORD FIELDS 

 
 
 
 
 
 
 

 

A
.  D

ata R
ecord

 
Field

s  



 
 

 

 
 



 

Appendix A Data Record Fields  A-1 
Release 115-780-011A, Release Date 02 May 2024 

Table A1 lists the TAGS-7 data records information. Marine or 
airborne specific fields contain zero when not applicable to the 
specific meter type. For Example: The Speed data field is only 
applicable to marine gravity systems. This field contains zero for 
airborne gravity systems.  

Refer to Section 03 of the manual for configuring system 
settings. Refer to Section 05 for additional data specific 
information.  

User specified fields include: 

• Specifying the delimiter character 
• Checksum added to the end of the string. 
• String can be fixed with or compressed with all spaces 

removed.  
• Carriage return and /or line feed character(s) can also be 

added to the end of the string. 
 

Example: 

$MGS6,2015,7,23,14,56,35,0,1119710.5368,145921.2662,100,
5476.8483,88.99315,88.99315,55.905,7.796,3.345607,6378.68
3406,0.000,-980167.954,39.978940,-
105.068153,136.700,0.000,158,0,300044 

about:blank
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Table A-1 TAGS-7 Data Record Fields 

DATA FIELD FIELD LENGTH UNITS FILTERING 

ID comma delimited “$MGS6” N/A 

Year delimited YYYY N/A 

Month delimited MM N/A 

Day delimited DD N/A 

Hour delimited HH N/A 

Minute delimited MM N/A 

Second delimited SS N/A 

Millisecond delimited SSS N/A 

Raw Gravity delimited Milligal 20Hz FIR (fixed)  

Corrected Gravity delimited Milligal 20Hz FIR (fixed) 

Filter Window delimited Seconds N/A  

Filtered Corrected 
Gravity 

delimited Milligal Variable Length 
FIR (user editable) 

Long Level delimited Gals 20Hz FIR (fixed) 

Cross Level delimited Gals 20Hz FIR (fixed) 

Meter Temperature delimited DEGREES C 20Hz FIR (fixed) 

Meter Pressure delimited mbar 20Hz FIR (fixed) 

Beam delimited V 20Hz FIR (fixed) 

Vcc delimited  N/A 

Eotvos Correction delimited Milligal N/A 

IGF Correction delimited Milligal N/A 

Latitude delimited DD, +N N/A 

Longitude delimited DD, +E N/A 

Course delimited DEGREE N/A 

Speed delimited KNOTS N/A 

Status (TAGS/TAGS-6) delimited Integer N/A 

Timer delimited Milliseconds N/A 

Checksum (Optional) delimited Integer N/A 

 

 



 

APPENDIX B  QC FILTER COMPUTATION 

 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

B
. Q

C
 Filter C

om
p

u
tation

 



 
 

 

 
 



 

Appendix B QC Filter Computation  B-1 
Release 115-780-011A, Release Date 02 May 2024 

Overview 
The Turnkey Airborne Gravity System-7(TAGS-7) is the latest 
generation of dynamic gravity meters available from Microg 
LaCoste. The TAGS-7 User Manual provides succinct procedures 
for: 

 
Assume the QC filter is set to L seconds (usually 120 or 180 
seconds).  The FIR filter will be 2 1L +  seconds long, with a 
nominal cutoff period of 2L seconds. 

First, calculate the weights for an ideal FIR low-pass filter with 
cutoff at 2L seconds, length 2 1L + : 
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The sinc function is defined as 
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Next, calculate the weights for an Exact Blackman window of 
length 2 1L + .  The equation for the window weights is 
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Apply the window function to the filter weights: 
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Finally, normalize so that the sum of the filter weights is 1: 
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( )G k  is the final filter to be applied by convolution 
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